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What is Agilent RapidFire Integrator?

The Agilent RapidFire Integrator data analysis software can be used to
integrate all of the data points collected in a single Agilent G9214AA
RapidFire 360 High-throughput Mass Spectrometry System run.

Data can be acquired from LC/MS instruments controlled by the Agilent
MassHunter Data Acquisition software.

Each sequence of a RapidFire-MS batch is processed individually. There is no
limit on the number of plates.
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Installation

Installation

To install Agilent RapidFire Integrator software

Before you begin

The RapidFire Integrator data analysis software can be installed on any
personal computer.

If a previous version of the RapidFire Integrator software is already present
on the system, use the Add/remove programs utility in the Windows Control
Panel to remove it.

1 Double-click the Installer.exe file supplied by Agilent Technologies.
RFI «3 Installer. exe
4
.. Setup Launcher Unicode

2 Follow the prompts displayed by the installation wizard.

The software is installed in C:\ Program Files\ Agilent\ RapidFire Integrator\.
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Preparing Data Collected in Plates Mode for RapidFire Integrator

Preparing Data Collected in Plates Mode for RapidFire Integrator

A run in Plates mode is defined as the data that is collected when you click the
Play button. Unlike Sequences mode, data acquired in Plates mode are named
and saved in folders with different names on the RapidFire and MS
computers.

To prepare Agilent MassHunter data

Repeat this process for each RapidFire-MS run.

1 Rename the MS data files to sequencel.d, sequence2.d, sequence3.d, and so on.

2 Copy the following files to a unique folder, such as \data sequenceX\:
sequenceX.d

batch.rftime (from the RapidFire computer, see “RapidFire data” on
page 13)

sequenceX.tofmap.txt

Agilent RapidFireData Analysis Guide 3



Analyzing Data in RapidFire Integrator

Analyzing Data in RapidFire Integrator

To access data acquired in Sequences mode

1 Open the configuration file in which the variable BASE_DATA_DIR is set:
C:\Program Files\ Agilent\ RapidFire\ cfgs\ RFMassHunterS.cfg
2 Locate the variable BASE_DATA_DIR.

Typical value for BASE_DATA DIR is:
D:\ MassHunter\ Data\ RapidFire\
3 Make note of the path name that is assigned to BASE_DATA_DIR.
Tip The following files are automatically moved to a unique folder, such as

D:\ MassHunter\ Data\RapidFire\2011\April\b\1\ (for the first run on April 5,
2011):

batch.rftime (automatically transferred from the RapidFire computer to
the MS computer)

sequenceX.d

sequenceX.tofmap.txt
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To analyze date in RapidFire Integrator

To analyze date in RapidFire Integrator

1 Double-click the desktop shortcut to start the Agilent RapidFire Integrator
software.

%

RF Integrator

2 Click File > Load TOF Data Set.
3 When the Browse For Folder window appears:

a Select the folder that contains the .D, .RFTIME and .TOFMAP.TXT files.

& RapidFire Integrator [Bm",“ For Folder W

Desktop
@ () My Documents
i My Computer
& % by Network Places
2 Recyrls Bin
= 3 DEMO DATA
® 2 sequencel.d
® () OTHER

MaksNewFolder | ok | [ cancel |

b Click OK.
4 Click Data > Extract TOF XICs.

5 Set the following parameters on the TOF Options Form dialog box, then
click OK:

* Display Time Range (set to all by default)
* Polarity

* Error (ppm), which determines the accuracy

* Whether or not to Use Internal Standard, and if marked, then enter the
mass of the internal standard
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To analyze date in RapidFire Integrator

Lo Erﬁ'pﬁo nsForm m

Please Set TOF Configuration Parameters

"D\splay Time Range

& Al € Tuncated
Folarity
’7 & Positive " Negative
Enor (ppm)
10

Intemal Standard (before polarity mod)

4931438 ¥ Use Irtermal Standard
oK

2

6 Select Minutes for the MS data files time units.

Mass Spec Data Time Speci'f‘icalinn

Please indicate the units in which time is
measured in the mass spec data files

* Minutes " Seconds

o

7 Click to select the sequence of interest in the left pane, as shown for
Sequence 1 in the following example.

m
x

& File Window Help o

Fntegratmn Parameters

seerce [ Same [Tmpma =] Y| T, T, 0 ﬂ Show [2 == Graphs

O 5equence 1
[260.1572
( 254

[ 365.0324
[ 368.1564
O3va.2103
O4231413
4280921
[ 494.1438
[ 494.1438
[0 497.2452
608 2345 q

8 Review the data using the following features:

* Click the + sign next to the sequence to display more information about
the sequence, such as plate name, and m/z chromatograms.
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To analyze date in RapidFire Integrator

Right-click in the left pane to display the following menu options:

Check Al
Uncheck al
Expand All

Collapse Al

Click to select the number of graphs to display in the upper right area of
the window.

Drag the mouse to select an area of the graph to expand. Repeat to
expand the area further.

Right-click in the graph and select Un-zoom to zoom out each successive
level.

9 Integrate peaks as follows:

a Zoom in on a known landmark peak within the sequence.
Any peak within the experiment can be selected as a landmark.
Data analysis can be based on any extracted mass.
Monitored analytes are identified by their m/z (title of the plot).
Use the scroll bar on the right side of the window to navigate from one
m/z to another.

b Select the identity of the peak from the Sample list.
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To analyze date in RapidFire Integrator

¥ Fle Window Help B
Integration Parameters e
(Sequence [ sampief{1 = 2001, 21 vN N IRAE T, [0 [ Show [2 = Graphs
Tat @3 |~
28t 0.1) 1
i
= D Sequence 1 atll,
oo\ [pai@0ia
[]ze01572 7at23
[EERCE azs) |
00133 T
50324
[]36a 1564
WEEL
4221413
04280021
41433
41438
O 4e7.2452
E15022345 .
5082345 [ Sequence 1)
D
an
-
- m
e
Fw
2w
m
-
.
ps & B i -
T )
4] |
&l m ] (2]

¢ Drag the mouse in a thin slab rectangle from the front edge of the peak to
its tail end to set the peak width for integration for area-under-the-curve
(AUC) calculations.

The defined time range is displayed in the Ty and Ty boxes above the
graph, and area also emphasized by teal coloring as shown in the
following example:
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To analyze date in RapidFire Integrator

# File window Help

1
om
x

”M[Egla[iun Faiameters

Seqerce [T Sanple e < YT EE T, 55D“

Show |2 3: Graphs

=[] Sequence 1

= O plate12
~[Q2s01872
~[O319103
~[O34013e3
~[Qs50324
~[]3881564
~[O3782102
~[42318413
Q4230921
Q4941438
Q4941428
[ 497 2452
- [F1508.2345

5082345 (Sequence 1)

ntanalty (1043 )
B EHHEHEEE

P P P © @
T )
< ]

&l ] Bl

d Click the summation button to process the data for the current sequence.

by

All masses of the sequence are processed together.

AUCs of injections turn blue, but background signals remain red.
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To analyze date in RapidFire Integrator

10

¥ File Window Help - |5 =

Integration Parameters
FEWWE [ sample [1a (2002 ~ Z T, 525 T, =5 ﬂ Show [B = Graphs
= [J Sequence 1
=-[rlate12

[0 2601572
O x49.1038
[0 3401383
[0 365.0324
[ 368.1564
032103
04231413 i
4280921 ==
[0 4941438 =

[0 4941438
[0 4972452
608 2345

e

et

=B gglUp

[r——
=g EEEEERE

] |
&l 0 A

e To save partial progress in data analysis before all of the sequences of
the run are analyzed, click File >Save As.

The results are saved in the specified .RFD file.

Partially processed experiment files can be reopened by clicking File >
Open.

10 Export data.

a When processing is complete for all the sequences of a run, click File >
Export Peak TOF Format to export the data.

A .RFPKS text file is created, which contains a list of injections.
Only the masses of interest are reported for each well.

You can analyze this file with a spreadsheet program. An example file
opened in Microsoft Excel is shown on the next page.
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To analyze date in RapidFire Integrator

Sip  Sequence PlateName

DEMO PLATE
DEMO PLATE
DEMO PLATE
DEMO PLATE
DEMO PLATE
DEMO PLATE
DEMO PLATE
DEMO PLATE
DEMO PLATE
DEMO PLATE
DEMO PLATE
DEMO PLATE
DEMO PLATE
DEMO PLATE
DEMO PLATE
DEMO PLATE

Wl N e R W e

= B
ShEEREES

1

e R e e SR

Row

-

Column

3
Injection
time (sec)

9.23

18.46

27.27

36.17

44.41

53.51

62.25

71.09

79.42

88.65

97.63

106.48

114.92

124.15

133.16

141.98

Mass 1
507.2345
507.2345
507.2345
507.2345
327.1947
327.1947
327.1947
327.1947
427.0921
427.0921
427.0921
427.0921
318.1038
318.1038
318.1038
318.1038

Abundance 1 Mass 2

10648
2992271
3061670
2900104

0
1819135
1888354
1403209

41
1135663
195475
292988
311

31407

29637

34226

493.1438
493.1438
493.1438
493.1438
493.1438
493.1438
493.1438
493.1438
493.1438
493.1438
493.1438
493.1438
493.1438
493.1438
493.1438
493.1438

Abund:

b You can also export data using File > Export Peak Data,

A .RFPKS text file is created, which contains a list of injections.

All the masses of interest throughout the sequence are reported for
every well.

You can analyze this file with a spreadsheet program, as shown in the
following example in Microsoft Excel.

A
Sequence 1

|PlateName

DEMO PLATE
|DEMO PLATE
DEMO PLATE
|DEMO PLATE
DEMO PLATE
|DEMO PLATE
DEMO PLATE
10 DEMO PLATE
11 |DEMO PLATE
12 DEMO PLATE
13 |DEMO PLATE
14 DEMO PLATE
15 |DEMO PLATE
16 DEMO PLATE
17 |DEMO PLATE
18 DEMO PLATE

W oo || bW e

Row

IS

Column

260.1572 319.1038

4277
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]

139
265
715
54
479
1079
708
638
960
487
429
311
31407
29637
34226

328.1947 340.1383 365.0324 368.1564 378.2103 423.1413

6

ERE=RE=NI=]

1819135
1888354
1403209
1295.5
2248

oo oo oo

681
8994
24523
13564
299
16647
1880
2532
109.5
10454
991
632.5
28
838
300.5
554

1738
23
73.5

9332 750
30920 675
28588 1319.5

o 836.5

o 233
629 698
228 851
21 486
o 470
277 412
o 350

o 309

o 339

o 430
4.5 212.5
206

428.0921
1085
24

819

327

0

424

482

224

a1
1135663
195475
292988
0

14744
743

315

M
INTERNAL
STANDARD
494.1438
2747
297438
490474
475369.5
4295
574327
552930
517027
4003.5
527503
503490
4923375
2913
545323
505078.5
490114

497.2452
12245
4205
8052
6326
2197
8337
8459
9308
2713.5
8916
7489.5
7719
2301
39815
340302
40181

508.2345
10648
2992271
3061670
2900104
4893
82630
23723
9391
3307
25129
11622
7239.5
2620
14282
6610
4813

B
Injection
time (sec)

9.23
18.46
27.27
36.17
44.41
53.51
62.25
7109
79.42
88.65
97.63

106.48
114.92
124.15
133.16
141.98

1"



Data Analysis Reference

Data Analysis Reference

The following reference material applies to RapidFire Integrator data analysis
software.

Data files

The following file types make up a data set for analysis with the RapidFire
Integrator software when used for data acquired with the RapidFire-MS
System. These file types must be present in the same folder.

* batch.rftime file from the RapidFire computer

¢ sequenceX.d mass spectrometer (MS) data files. These are full scans
acquired by the TOF and can be several gigabytes in size.

¢ A .tofmap.txt tab-delimited text file, which you create to indicate the
platemap of the experiment. The platemap indicates the exact masses of
interest that are expected for each well.

Here is an example folder that contains the three required files:

| Chsequencel.d File Folder
m batch, rftime 2KBE RFTIME File
E] Exact mass plate map.tafrap, bxk 2ZKB Text Docurment

If the data is acquired within a single experiment in Plates mode, then
multiple 96-well or 384-well plates are analyzed within a single folder.
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RapidFire data

RapidFire data

RapidFire data is stored in a folder within the operating system software. A
new data folder is created each day with the date as the folder name.

A new folder is created each time a new experiment (in Plates mode) or a new
batch (in Sequences mode) is started within the RapidFire acquisition
software. A data file named batch.rftime is saved in that folder.

Example The first run performed on April 5, 2011 is saved in the following folder on the
RapidFire computer:

C:\ Program Files\ Agilent\ RapidFire\ data\ 2011\ April\ 5\ 1

Data columns

The following columns of data are saved in the data file:

Plate identity

Injection number

Sequence number

Row

Column

Time stamp (actuation of valve 2 from inject to load position: start of
elution)

Sip sensor value = The displayed value is 1 if the optical sip sensor
detected the presence of liquid, or 0 if it did not.

Example
A
plate

B
sip

C

D

seq row

col

E

F
siptime

G
sip sensor

DEMO PLATE
DEMO PLATE
DEMO PLATE
DEMO PLATE
DEMO PLATE
DEMO PLATE
DEMO PLATE
10 DEMOQ PLATE
11 |DEMO PLATE
12 |DEMO PLATE
13 |DEMO PLATE
14 |\ DEMO PLATE
15 |DEMO PLATE
16 |DEMO PLATE
17 |DEMOQ PLATE
18 |DEMOQ PLATE

W a ;W e

[C R R T R N

11
12
13
14

16

R R R = = N R R R i )
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3.304
12.529
21.341
30.238
38.486
47.582
56.322
65.164

7343
82.726
91.705

100.552
108.996
118.225
127.228
136.047

0
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1

WASH STATION

Bl
B3
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Mass spectrometry (MS) data

Mass spectrometry (MS) data
The path where the MS data is automatically stored on the MS computer is
specified by the variable BASE_DATA_DIR, which is defined in:
C:\Program Files\ Agilent\ RapidFire\ cfgs\ RFMassHunterS.cfg
Typical value for BASE_DATA_DIR is:
D:\ MassHunter\ Data\ RapidFire\

In Sequences When data is acquired in Sequences mode, the MS data is automatically
mode named and saved in folders with the same names on the RapidFire and MS
computers.

& D:\MassHunter\Data\RapidFire\2010\Mugust\10

File Edit ‘“iew Favorites Tools Help

eBack M 7 | l? /.._\JSearch i Folders v

Address |uﬂ [niMassHunker\DatalRapidFirel 201 0\ Augusti 10 <—

. Mame
" File and Folder Task A8
| File and Folder Tasks 4.-151

I ) Wake a new folder =

]
A Puhlish Hhis Frlder ta the
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Exact mass platemap

Exact mass platemap

The scientist must provide a .tofmap.txt file describing the platemap of the run.
The platemap indicates the exact mass of the compounds for each well
injected. The RapidFire Integrator uses these values to extract the appropriate
ion chromatograms from the TOF data for each well.

Example

1
2
3
4
5
6
7
8
2

10
11
i
13
14
15
16
17
18

A B Cc D
Sequence Row Column EXACT MASS

=
Internal standard

2001
1
1
1
2001
Lz
2
L
2001
3
3
3
2001
q
q
q

507.2344911
507.2344911
507.2344911
507.2344911
327.1946771
327.1946771
327.1946771
327.1946771
427.0921388
427.0921388
427.0921388
427.0921388
318.1038131
318.1038131
318.1038131
318.1038131

R R =R R N O R R R R
DWW W e W e R

Platemap file format

493.14382
493.14382
493.14382
493.14382
493.14382
493.14382
493.14382
493.14382
493.14382
493.14382
493.14382
493.14382
493.14382
493.14382
493.14382
493.14382

WASH STATION

B1
B3

The columns in the .tofmap.txt must appear in the following order:

sequence number
row
column

exact mass 1

exact mass 2, and so on

Additional columns can be appended as needed.

Agilent RapidFireData Analysis Guide
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