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Data Analysis with RapidFire Integrator or MassHunter Quantitative Analysis

Data analysis with MassHunter Quantitative Analysis
Data Analysis with RapidFire Integrator or MassHunter 

Quantitative Analysis

RapidFire 365 data can be acquired from triple-quadrupole (QQQ) or 
time-of-flight (TOF/QTOF) LC/MS instruments controlled by the Agilent 
MassHunter Data Acquisition software or other software, such Analyst or 
Xcalibur.

After data acquisition is completed (see G9530-90000 RapidFire 365 User 
Guide), you can process the data using RapidFire Integrator as described in 
this guide.

• The Agilent RapidFire Integrator data analysis software can be used to 
integrate all of the data points collected in a single Agilent G9530AA 
RapidFire 365 High-throughput Mass Spectrometry System run.

• Each sequence of a RapidFire-MS batch is processed individually. There is 
no limit on the number of plates. 

For data that was acquired with Agilent MassHunter Data Acquisition 
software, RapidFire 365 data can also be processed using Agilent MassHunter 
Workstation Software Quantitative Analysis. For more information, see:

• “Data analysis with MassHunter Quantitative Analysis” below, and 

• G3335-90152 Agilent MassHunter Workstation Software Quantitative 
Analysis Familiarization Guide.

Data analysis with MassHunter Quantitative Analysis

During the RapidFire-MassHunter data acquisition, data files (.D) are 
generated for each sequence.

The total ion chromatogram (TIC) can be viewed in real time in MassHunter 
Data Acquisition (MHAcq), and can be inspected further in MassHunter 
Qualitative Analysis.

After a run has completed, the original data files (long sequenceX.D files that 
are generated by MassHunter Data Acquisition and RFDataBase.XML files that 
are generated by RapidFire) must be split into individual injection files for the 
standard data analysis by MassHunter Quantitative Analysis software.
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Data Analysis with RapidFire Integrator or MassHunter Quantitative Analysis

To convert data for use with MassHunter Quantitative Analysis
To convert data for use with MassHunter Quantitative Analysis

1 In the RapidFire user interface, click File > Convert MS Data.

2 On the Convert MS Data dialog box:

a Select the whole-experiment data directory (Data Path) you want to 
convert.

b Select where to save the resulting single-injection data files (Save To).

The data path of the latest run is displayed as a default selection.

c Click Convert. 
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Data Analysis with RapidFire Integrator or MassHunter Quantitative Analysis

To convert data for use with MassHunter Quantitative Analysis
3 View the list of converted files as shown in the following example. 
The single-peak data files are automatically named InjXXXXX-barcode-well.d, 
where:

• "XXXXX" is the injection order in the RapidFire batch.

• "barcode" is the plate name.

• "well" is the plate position of the sample on the RapidFire platemap.

4 Proceed with viewing and processing the single-injection data files, as 
described in MassHunter Quantitative Analysis online Help and manual.
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Installation

To install Agilent RapidFire Integrator software
Installation

To install Agilent RapidFire Integrator software

The RapidFire Integrator data analysis software can be installed on any 
personal computer. 

Before you begin

Contact your Agilent field support engineer to request a copy of the latest 
RapidFire Integrator program, as well as the following prerequisite Windows 
components:

• Microsoft .NET 4.0 framework

• Visual C++ runtime libraries

To install RapidFire Integrator

1 Copy the entire RapidFire Integrator folder and paste it into C:\ Agilent\.

2 Create a shortcut to the RapidFire Integrator.exe file and place it on the 
computer desktop. 
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Location, Format, and Preparation of Data for RapidFire Integrator

Location of data
Location, Format, and Preparation of Data for RapidFire 

Integrator

The following reference material applies to RapidFire Integrator data analysis 
software.

Location of data

RapidFire data is stored in the folder D:\ MassHunter\ Data\ RapidFire\ on the 
MS computer. 

• A new data folder is created each day with the date as the folder name. 

• A new folder is created when a new experiment (in Plates mode) or a new 
batch (in Sequences mode) is started in RapidFire acquisition software.

Example The first run performed on April 5, 2013 is saved in the following folder on the 
MS computer: 

D:\ MassHunter\ Data\ RapidFire \ 2013\ April\ 5\ 1

NOTE
The data file folders that are created by MS computer settings may be different than the 
scheme described above. Refer to the BASE_DATA_DIR variable in RFMassHunterS.cfg 

on your MS computer, which is located in C:\ Agilent\ RapidFire Communicator\ cfgs\.

NOTE
If the RapidFire front end is connected to an AB Sciex MS, then the data are stored in 
D:\ Analyst Data\ RapidFire\ and BASE_DATA_DIR = "D:\ Analyst Data\ RapidFire" in 
RFAAOS.cfg on your MS computer.
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Location, Format, and Preparation of Data for RapidFire Integrator

Data files
Data files

A data set for analysis with the RapidFire Integrator software includes the 
following types of files. These files must be present in the same folder. 

• batch.rftime 

• sequenceX.d mass spectrometer (MS) data files in MassHunter, or 
sequenceX-xic-YZ.rfxic in AB Sciex Analyst or Thermo Fisher Xcalibur

• A platemap.tofmap.txt tab-delimited text file, for RapidFire-TOF/QTOF 
systems. The original platemap.tofmap.txt file is first empty. Modify it as 
described on page 9.

The following example data folder of a RapidFire qTOF shows the three 
required file types:

If the data is acquired within a single experiment in Plates mode, then 
multiple 96-well or 384-well plates are analyzed within a single folder.

The following columns of data are saved in the batch.rftime text file:

• Plate identity

• Injection number

• Sequence number

• Row

• Column

• Sip Time, the time stamp for the actuation of valve 2 from inject to load 
position, as well as the start of elution to MS.

• Sip sensor value. The displayed value is 1 if the optical sip sensor 
detected the presence of liquid, or 0 if it did not.
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Location, Format, and Preparation of Data for RapidFire Integrator

Data files
Example

NOTE
• The aqueous and organic wash stations, WASH1 and WASH2, have (row, column) addresses of 

(2001, 2) and (2001, 3), respectively.
• The matrix vials MAT1, MAT2, MAT3, and MAT4 have (row, column) addresses of (1001, 2), (1001, 

3), (1001, 4), and (1001, 5), respectively.
• If data were acquired in Plates mode, make sure to name or rename the MS data files to 

sequence1.d.
• If the RapidFire front end is connected to an AB Sciex QQQ, then the .WIFF MS data files are 

automatically processed by the RapidFire software and transformed into text files called 
sequenceX-xic-Q1---Q3.rfxic.
8 Agilent RapidFireData Analysis Guide



Location, Format, and Preparation of Data for RapidFire Integrator

Exact mass platemap
Exact mass platemap

For data that were acquired via RapidFire-QTOF in MS/MS mode, you don’t 
need to modify the platemap.tofmap.txt file.

For RapidFire-TOF/QTOF experiments in MS mode, modify platemap.tofmap.txt 
to specify the exact masses of the compounds of interest for each well that was 
injected. The RapidFire Integrator uses these values to extract the appropriate 
ion chromatograms from the TOF data of each well. For data that are acquired 
in MS mode, the columns of data in the platemap.tofmap.txt text file are: 

• Sequence number

• Row

• Column

• Exact mass 1 (or chemical formula 1)

• Exact mass 2 (or chemical formula 2), and so on

More columns can be appended as needed.

Example
Agilent RapidFireData Analysis Guide 9



Loading RapidFire-QQQ Data in RapidFire Integrator

To prepare Agilent MassHunter data
Loading RapidFire-QQQ Data in RapidFire Integrator

A run in Plates mode is defined as the data that are collected without setting 
up a batch. Unlike Sequences mode, data acquired in Plates mode are named 
and saved in folders possibly with different names and locations on the 
RapidFire and MS computers.

If the data are collected in Plates mode with MassHunter, Analyst, or Xcalibur, 
then prepare the data as described in this section before you analyze it with 
RapidFire Integrator.

If the data are collected in Sequences mode, then proceed with “To open 
RapidFire-QQQ data” on page 16.

To prepare Agilent MassHunter data

Repeat this process for each RapidFire-MS run.

1 Rename the MS data files to sequence1.d.

2 Copy the following files to a unique folder, such as \data sequenceX\:

• sequence1.d.

• batch.rftime (from the RapidFire computer, see “Data files” on page 7. 
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Loading RapidFire-QQQ Data in RapidFire Integrator

To prepare AB Sciex Analyst data
To prepare AB Sciex Analyst data

1 Open the Analyst program.

a Click Explore > Open Data File.

b Select the appropriate .WIFF file from the list.

c Click to select the sample of interest, then click OK.

The MS chromatogram traces for the selected sample appear in the main 
window.

2 Create extracted ion chromatograms (XIC) as follows:

a Click on the XIC button on the Analyst toolbar.

b Click to select the masses of interest, which are the individual MS 
chromatograms for each of the MRM channels that were monitored 
during the experiment.
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Loading RapidFire-QQQ Data in RapidFire Integrator

To prepare AB Sciex Analyst data
3 Save each XIC as a text file as follows:

a Right-click on the panel for the XIC of interest and select Save to Text 
File.

b Select the folder where you want to save the file. Use the same directory 
where the RapidFire batch.rftime data file is already saved.

c Name the MS data files sequence1-xic-XXX.txt, where XXX is any unique 
string of alphanumerical characters, such as sequence1-xic-MSprod.txt.
12 Agilent RapidFireData Analysis Guide



Loading RapidFire-QQQ Data in RapidFire Integrator

To prepare Thermo Fisher Xcalibur data
To prepare Thermo Fisher Xcalibur data

1 Open the Xcalibur program.

a Click File > Open.

b Select the appropriate .RAW file from the list.

c Click Open.

The MS chromatogram traces for the selected sample appear in the main 
window.

2 Create extracted ion chromatograms (XIC) as follows:

a Right-click right on the total ion chromatogram (TIC) and select 
AutoFilter.

b Delete the TIC panel at the top of the window.
Agilent RapidFireData Analysis Guide 13



Loading RapidFire-QQQ Data in RapidFire Integrator

To prepare Thermo Fisher Xcalibur data
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Loading RapidFire-QQQ Data in RapidFire Integrator

To prepare Thermo Fisher Xcalibur data
3 Save each XIC as a text file as follows:

a Right-click on the panel for the XIC of interest and select Export to 
Clipboard (Chromatograms).

b Paste the selection into Excel.

c Save it as a text file (.TXT) in the same directory where the RapidFire 
batch.rftime data file is already saved.

d Name the MS data files sequence1-xic-XXX.txt, where XXX is any unique 
string of alphanumerical characters, such as sequence1-xic-MSprod.txt.
Agilent RapidFireData Analysis Guide 15



Loading RapidFire-QQQ Data in RapidFire Integrator

To open RapidFire-QQQ data
To open RapidFire-QQQ data

1 To start the Agilent RapidFire Integrator software, double-click the desktop 
shortcut

. 
2 Click File > Load RF300-QQQ Data. 

3 When the Browse For Folder window appears:

a Select the folder that contains the .RFTIME and .RFXIC or .D files. 

b Click OK.

4 Continue with “Analyzing Data in RapidFire Integrator” on page 20.
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Loading RapidFire-TOF/QTOF Data in RapidFire Integrator

To open RapidFire-TOF/QTOF data
Loading RapidFire-TOF/QTOF Data in RapidFire Integrator

To open RapidFire-TOF/QTOF data

1 To start the Agilent RapidFire Integrator software, double-click the desktop 
shortcut.

 

2 Click File > Load RF360-TOF/QTOF Data.

3 When the Browse For Folder window appears:

a Select the folder that contains the .D, .RFTIME and platemap.TOFMAP.TXT 
files. 

b Click OK.

4 Click Data > Extract TOF/QTOF XICs. 
Agilent RapidFireData Analysis Guide 17



Loading RapidFire-TOF/QTOF Data in RapidFire Integrator

To open RapidFire-TOF/QTOF data
5 For data that were acquired with a TOF or with a QTOF in MS mode:

a Set the following parameters on the TOF Options Form dialog box:

• Display Time Range (set to all by default)

• Polarity

• Error (ppm), which determines the accuracy

• Whether or not to Use Internal Standard, and if marked, then enter the 
mass of the internal standard. To extract multiple internal standards in 
every well of the RapidFire-TOF run, enter their masses separated by 
commas (,).

b Click OK to close the TOF Options Form dialog box.

6 For data that were acquired with a QTOF in MS/MS mode: 

a Click Add on the QTOF Options dialog box.

b In the Add Product Ion dialog box:

• Select Sequence and Precursor Ion from the drop-down fields.

• Type in the mass or chemical formula of one Product Ion of interest and 
the Error (ppm).

• Click OK.

c Repeat for all Precursor Ions and all Product Ions of interest.
18 Agilent RapidFireData Analysis Guide



Loading RapidFire-TOF/QTOF Data in RapidFire Integrator

To open RapidFire-TOF/QTOF data
d When you are finished, click OK to close the QTOF Options dialog box.

7 Select Minutes for the MS data files time units.
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Analyzing Data in RapidFire Integrator

To open RapidFire-TOF/QTOF data
Analyzing Data in RapidFire Integrator

1 Click to select the sequence of interest in the left pane, as shown for 
Sequence 1 in the following example.

2 Review the data using the following features:

• To display the list of m/z, click the + sign next to the sequence.

• To display the following menu options, right-click in the left pane:

 

• Click to select the number of graphs to display in the upper right area of 
the window.

• To select an area of the graph to expand, drag the mouse. Repeat to 
expand the area further. 

• To zoom out each successive level, right-click in the graph and select 
Un-zoom.
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Analyzing Data in RapidFire Integrator

To open RapidFire-TOF/QTOF data
3 Integrate peaks as follows:

a Zoom in on a known landmark peak within the sequence. 

• Any peak within the experiment can be selected as a landmark.

• Data analyses can be based on any mass.

• The title of the plot identifies monitored analytes by their m/z.

To navigate from one m/z to another, use the scroll bar on the right side 
of the window.

b Select the identity of the peak from the Sample list.

c Define the peak to integrate for area-under-the-curve (AUC) calculations 
in either of the following ways:

• Drag the mouse in a thin slab rectangle from the front edge of the peak to 
its tail end.

• Use the keyboard to type in the T1 and T2 times.

The defined time range is displayed in the T1 and T2 boxes above the 
graph. The peak area is also emphasized by teal coloring as shown in the 
following example.
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Analyzing Data in RapidFire Integrator

To open RapidFire-TOF/QTOF data
d To process the data for the current sequence, click the summation 
button.

  

• All masses within the same sequence are processed together.

• AUCs of injections turn blue, but background signals remain red.

e Repeat Steps 3a. through 3d. for each sequence of the run.
22 Agilent RapidFireData Analysis Guide



Analyzing Data in RapidFire Integrator

To open RapidFire-TOF/QTOF data
4 To save partial progress in data analysis before all of the sequences of the 
run are analyzed, click File > Save As. 

• The results are saved in the specified .RFD file.

• Click File > Open to reopen experiment files that have been partially 
processed.
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Analyzing Data in RapidFire Integrator

To open RapidFire-TOF/QTOF data
5 To export data that were acquired with a QQQ:

• Click File > Export Peak Data List.

A .RFPKS text file is created, which contains a list of injections.

You can analyze this file with a spreadsheet program. The following is an 
example file opened in Microsoft Excel.
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Analyzing Data in RapidFire Integrator

To open RapidFire-TOF/QTOF data
6 To export data that were acquired with a TOF or QTOF in MS mode:

• Click File >Export Peak Data TOF.

A .RFPKS text file is created, which contains a list of injections.

Only the masses of interest are reported for each well.

You can further analyze the results with a spreadsheet program. The 
following is an example file opened in Microsoft Excel.
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Analyzing Data in RapidFire Integrator

To open RapidFire-TOF/QTOF data
7 To export data that were acquired with a QTOF in MS/MS mode:

• Click File > Export Peak Data List.

A .RFPKS text file is created, which contains a list of injections.

Only the precursor ion : product ion pairs of interest are reported for each 
sequence.

You can further analyze the results with a spreadsheet program. The 
following is an example file opened in Microsoft Excel.
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Analyzing Data in RapidFire Integrator

To open RapidFire-TOF/QTOF data
8 To export RapidFire-QQQ data by plates:

• Click File > Export Peak Data Plate-wise. 

Keep in mind the following caveats:

• Data for MAT# and WASH# injections are not displayed.

• This option is only offered if each sample well within a plate is visited 
only once.

You can analyze this file with a spreadsheet program, as shown in the 
following example in Microsoft Excel.
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Analyzing Data in RapidFire Integrator

To open RapidFire-TOF/QTOF data
9 To export RapidFire TOF or QTOF data acquired with MS mode:

• Click File > Export Peak Data TOF.

A .RFPKS text file is created, which contains a list of injections.

Only the masses of interest are reported for each well.

You can further analyze the results with a spreadsheet program. The 
following is an example file opened in Microsoft Excel.
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Analyzing Data in RapidFire Integrator

To open RapidFire-TOF/QTOF data
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