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What is RapidFire Analyzer?

RapidFire Analyzer is a data analysis program that allows you to rapidly process, 
review, and report semi-quantitative RF/MS/MS data acquired by an Agilent 
RapidFire 200/300/360/365 High-throughput Mass Spectrometry System in 
Multiple Reaction Monitoring (MRM) mode.

RapidFire Analyzer is primarily designed to quickly evaluate large panels of 
results and identify compromised samples. RapidFire Analyzer allows you to 
simultaneously view a large array of chromatographic peaks, perform 
calculations and normalizations, and highlight flagged errors.

Where to Find More Information

Help

The online Help provides in-depth information about how to configure and use 
RapidFire Analyzer. 

To access online Help, click Help on the tool bar.

Technical Support

Technical support in United States and Canada: 
1-800-227-9770, and select option 3

Worldwide technical support:   visit www.agilent.com

https://www.agilent.com/en/contact-us/page
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Installation

Before you begin

Make sure that your computer meets these minimum requirements:
• Windows 7 64-bit or Windows 10 64-bit operating systems
• 2 GHz or faster 64-bit processor, multicore preferred
• 4 GB RAM
• 40 GB hard drive capacity with 10 GB free space
• Graphics hardware acceleration with 1280 x 1024 or higher screen 

resolution
• .Net Version: 4.0 or higher
• RapidFire version 4.3.0.17235 or RapidFire version 5.0.0.18130 for 

synchronized (or sequence-mode) 6400 Series LC/MS only.
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To install RapidFire Analyzer from a disc

1 Insert the installation disc into the disc drive. 

If the installation program does not automatically start, from the installation 
disc, double-click setup.exe,

2 In the Welcome to the RapidFire Analyzer Setup Wizard dialog box, click 
Next.

3 In the End-User License Agreement dialog box:
a Carefully read the license agreement. 
b Print the agreement and then click Back.
c Select I accept the terms in the License Agreement to accept the license 

agreement, and then click Next.
4 In the Installation Scope dialog box, choose whether to install for just 

yourself or for all users on this computer, and then click Next.
• Install just for you (username) installs RapidFire Analyzer in your personal 

folder. The program is available to only your user account.You do not need 
administrator privileges for your computer. 

• Install for all users of this machine installs RapidFire Analyzer all users on 
this computer. You must have local administrator privileges for this 
computer.

NOTE
If you are not able to install RapidFire Analyzer, contact your network 
administrator for assistance. Make sure that you have the appropriate local 
administrator privileges required to install the application on this computer.

5 In the Destination Folder dialog displays, choose whether to use the default 
folder or to specify a different location.
• To accept the default location, click Next to continue.
• To select a different location, click Change. Select the new location, and 

then click OK. Click Next to continue.
6 In the Ready to install RapidFire Analyzer dialog box, click Install to start the 

software installation process.
7 When the Completed the RapidFire Analyzer Setup Wizard dialog appears, 

click Finish.
8 Activate RapidFire Analyzer. See “To activate RapidFire Analyzer” on page 5.
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To download and install RapidFire Analyzer

1 Use the link that Agilent provided you to visit the software download location.

Agilent provides the link location when the software is purchased.
2 Select RapidFire Analyzer and click Download.

If the computer that is to run RapidFire Analyzer cannot access the Internet, 
then from a computer that can, save the installation files to an accessible 
medium such as a USB flash drive or a server on your company Intranet.

3 Extract the RapidFire Analyzer installation files to your computer.
4 Double-click setup.exe.
5 Continue the installation at step 2 of “To install RapidFire Analyzer from a 

disc” on page 4.
6 Activate RapidFire Analyzer. See “To activate RapidFire Analyzer” on page 5.

To activate RapidFire Analyzer

The first time you start RapidFire Analyzer after installation, you will need to 
enter a valid activation key. The activation key is supplied at the time of 
purchase.

Start the RapidFire Analyzer Activation

1 Start RapidFire Analyzer. See “To start RapidFire Analyzer” on page 14.
2 In the RapidFire Analyzer Activation dialog box, click Yes to continue.

The License Activation dialog box appears (Figure 1).
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Figure 1. License Activation dialog box

3 Choose the activation method:
• Choose to activate online if the computer has access to the Internet.
• Choose to activate manually if the computer does not have acces to the 

Internet, or if you are not able to access the license server.

Online Activation

1 Type the valid activation key into the Activation key box. 

The License Type displays Invalid because RapidFire Analyzer is currently 
not activated. The Machine Id identifies the name of your machine.

2 Click Online Activation.
3 Click Activate.

If the computer cannot access the license server, click Proxy Settings and 
check the settings. If you do not know the appropriate proxy settings, contact 
your network administrator for assistance. Enter the correct settings. 

If the computer still cannot access the license server, manually activate the 
license key.

4 Click OK to close the Key Activated message. 

The application closes and then restarts. RapidFire Analyzer is activated.
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Manual Activation

1 Make a note of the computer name and the activation key.
2 On a computer with Internet access:

a Go to license.rapidfireanalyzer.com.

b Click Activate.
c In the License Activation page, select the appropriate RapidFire Analyzer 

version.
d Type in the valid Activation Key.
e For Machine Id, type the computer name for the computer that is to run 

RapidFire Analyzer.

If this license key is valid for multiple computers, type all computer names, 
one computer name per line. You cannot enter more computer names 
than the Activation Key is assigned. 

f Click Activate.

The Activation Results page displays a list of computers that are 
activated, as well as those not activated.

g Click License Text.
g. Click License Text. The save license text prompt displays: (figure #17 Activate license 3.png)

h Save the LicenseText.txt file to a portable storage device, such as a USB 
flash drive. 

3 On the computer that is to run RapidFire Analyzer:
a In the License Activation dialog box, type the valid activation key into the 

Activation key box. 

http://license.rapidfireanalyzer.com
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The License Type displays Invalid because RapidFire Analyzer is currently 
not activated. The Machine Id identifies the name of your machine.

b Type the Machine Id (computer name).
c For Activation method, click Manual.
d If needed, attach or insert the medium that contains License Text.txt.
e Click Load From a File and locate LicenseText.txt file on the portable 

storage device.
f Click Open. 

The License Text displays in the License text box. 
g Click Activate. The Key Activated message displays. 

In the License Activation dialog box, the License Type changes from 
Invalid to Permanent or Evaluation. If you installed an evaluation copy, 
Expiration date displays. 

h Click OK to close the Key Activated message. 

The application closes and then restarts.  RapidFire Analyzer is activated.
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User Interface

RapidFire Analyzer Window

After data files are opened and injections are selected, various views are shown 
in the RapidFire Analyzer window (Figure 2). 

Click areas in the RapidFire Analyzer window for overview information. See 
“RapidFire Analyzer Menu” on page 10 for a list of tasks that you can do in this 
window.

Figure 2. RapidFire Analyzer with opened data files and selected injections
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RapidFire Analyzer Menu

Table 1 describes the RapidFire Analyzer menus.

Table 1 RapidFire Analyzer menus 

Menu Submenu Description

File Open Displays the Open RapidFire Files dialog box. Locate the 
RFDatabase.xml file you want to open and select it. Click Open 
to open the raw data file.

Close All Batches Closes all batches currently open.

Active Batch Closes only the active open batch.
If you have more than one batch open, the program closes only 
the active batch. 

Recent Data Files Displays previously-opened RFDatabase.xml raw data files. 

Exit Closes all open batches of samples and exits the program.

Edit Calculations Displays the Calculations Editor. Allows you to create or change 
calculations displayed in the injections list. 

Select All Injections Selects all injections for all plates in the active batch. 

Deselect All Injections Clears the selection of all injections in the active batch.

View Logging Console Displays the Logging Console. The console displays RapidFire 
Analyzer event information and errors.

File Opens a copy of the error log file (ASPROLog.txt) in a 
text-readable file format using Windows Notepad.

Settings Displays the Log System Settings dialog box where you can 
configure the error settings.

Containers Displays open batches. If multiple batches are opened, a specific 
Batch can be hidden by clearing the check box. The batch can be 
viewed by re-selecting it.

Group Views Displays the Chromatogram View for the Active Batch. Clear the 
check box to suppress the Chromatogram views.

Tools Preferences Displays the Workflow Preferences dialog box. It allows you to 
customize how chromatograms are displayed and labeled in the 
Chromatogram view. 

Settings Displays the Application Settings dialog. It allows you to set the 
default Method for the Application.

javascript:void(0);
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Help RapidFire Analyzer Help Displays the RapidFire Analyzer Online Help.

License Activation Displays the License Activation dialog box. 

About RapidFire Analyzer Displays the RapidFire Analyzer copyright information.

Table 1 RapidFire Analyzer menus (Continued)

Menu Submenu Description
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RapidFire Analyzer Views

RapidFire Analyzer provides several Views to work with your data.

Plate View Displays the available plates for the open data file, also known as the Active 
Batch. The wells for the selected plates are displayed in the Well View.

Well View Displays a summary of the selected plates. See Table 2 for a description of the 
information that is displayed.

Injection View Displays all injections, regardless of plate selection. The chromatograms for the 
selected injections are displayed in the Chromatogram View.

Chromatogram 
View

Displays the chromatograms for the injections that are selected in the Injection 
View.

Plate View

Well View

Injection View

Chromatogram View



User Interface
RapidFire Analyzer Views

RapidFire Analyzer Quick Start Guide 13

Table 2 Description of well indicators

Image Image Description Indication

White No injections are present

Grey background with no number A single injection is present.

Number on any background The number of injections that are present.

Grey background No special condition.

Red background At least one injection contains an error or 
warning, for example, a sip-sensor error.

Yellow background At least one injection has been manipulated. 
Possible manipulations include deletion or 
manual integration.

Black outline All injections are selected and displayed in the 
Chromatogram View.

Blue outline At least one injection is selected and displayed 
in the Chromatogram View.
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Basic Tasks

Before you do these tasks, make sure:
• The software is properly installed
• The software is activated with a valid activation key.

To start RapidFire Analyzer

• Double-click the RapidFire Analyzer icon on the desktop.

      

To open data files in RapidFire Analyzer

1 In RapidFire Analyzer, click File > Open > RapidFire RD DB(.xml).
2 In the Open File dialog box, find the folder that contains the raw data.
3 Select RFDatabase.xml, and then click Open. 

When you open an RFDatabase.xml data file, RapidFire Analyzer applies all 
settings for sample processing from the default method. The default method file 
included with RapidFire Analyzer is RapidFire Default_Agilent.method. For the 
majority of samples, these settings produce satisfactory results.

mk:@MSITStore:C:\Users\pattysun\Desktop\RapidFire Analyzer\RapidFire_Analyzer_Help.chm::/Basic_Software_Tasks/Generate_a_Set_of_.csv_Reports_for_a_Batch.htm
mk:@MSITStore:C:\Users\pattysun\Desktop\RapidFire Analyzer\RapidFire_Analyzer_Help.chm::/Basic_Software_Tasks/Generate_Single_.xls_Report_for_All_Injections_in_a_Batch.htm
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To open data files using a saved method different than 
the default

1 In RapidFire Analyzer, click Tools > Settings.
2 In the Application Settings dialog box, browse to and select the desired 

.method file and then click Open.
3 Click OK.
4 Open a data file as described above.

Please note that this process requires the alternative method file to have already 
been created and saved. See “To view, change, save, and apply methods” on 
page 20.
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To open data files using a specific calculations method

Use the Calculations tab to define the calculation template for each sample 
series imported and processed. 
1 Click Tools > Preferences.
2 In the Workflow Preferences dialog box, click the Calculations tab.

3 Select Use calculations template.
4 Click Browse and select the calculations template to use.
5 Click OK to save the changes.
6 Open a data file. 

See “To open data files in RapidFire Analyzer” on page 14 or “To open data 
files using a saved method different than the default” on page 15.

Please note that this process requires the calculations template to already 
exist. See “To view, change, and save calculations methods” on page 25.

Figure 3. Calculations tab
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To work with chromatograms

• To expand a single chromatogram, click the Expand button in the top right of 
each chromatogram pane. 

You can also double-click anywhere on the chromatogram.

      

• To close an expanded chromatogram, click the Close button in the top right 
of the pane.

You can also double-click anywhere on the expanded chromatogram.

      

• To act on chromatograms, refer to Table 3.

See Figure 4 on page 19 to see multiple chromatograms in Chromatogram View.
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Table 3 Chromatogram Actions
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.png).

Figure 4. Chromatogram View with multiple chromatograms
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To view, change, save, and apply methods

To view and change methods

1 Open a RapidFire data file. See the “To open data file” topics near the start of 
“Basic Tasks” on page 14.

2 Open an RFDatabase.xml data file.
3 Select one or more injections.
4 Identify a chromatogram to edit.
5 In the chromatogram pane, click the Method Editor button.

The Method Editor dialog displays. The Select MRM to use for tuning drop 
down panel displays the MRM of the pane in which you clicked the Edit 
Method button. 

6 Adjust the settings as needed. The changes are reflected in the 
Chromatogram View as you make changes.

To save the method as a new method file for future use

1 Click File > Save To File.
2 In the File name box, type a name for the new method.
3 Click Save.

All method settings, including the adjusted settings, are saved in a new 
filename.method file. This method can be used to process future data. See 
“To open data files using a saved method different than the default” on 
page 15.
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To apply the method settings to the open data file

1 Under the Chromatogram View, select either Sequence, Plate, or Batch.
2 Click Process. The changes are applied to the entire Sequence, Plate, or 

Batch.

To close the Method Editor without processing the data or saving any 
changes to the method, either click Cancel or click File > Close.

Note that the changes cannot be applied to a single injection. To change a 
single injection, you need to manually integrate it. See “To remove peak 
integration and reintegrate” on page 23 for more information.
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Figure 5. Method Editor
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To remove peak integration and reintegrate

If you need to reintegrate an individual chromatographic peak, you can remove 
the integration and then use Manual Integration to reintegrate it.

Figure 6. Reprocessing (left) and removing (right) MRM integration

• To remove an integration, in the individual chromatogram pane, click the 
orange Remove Peak Integration button. See Figure 6, right-side pane.

• To reintegrate the injection without applying any changes to the default 
parameters, click the bright green Reprocess the injection button. See 
Figure 6, left-side pane.

• To manually integrate the injection, right-click the bottom of one side of the 
curve and drag to the other side of the curve.

If the injection is manually integrated, the Manual Modification flag displays 
(Figure 7). The Well View shows a yellow condition indicator for that injection. 
However, if the well also experiences a more serious error (such as a 
sip-sensor error or a calculations or boundary error), the Well View shows a 
red condition indicator instead.

The Manual Modification flag displays whenever the injection integration 
differs from the original integration, regards of whether the injection is 
removed or is manually integrated.

If you manually integrate, and then reprocess an injection, the manual peak 
reintegrations are lost.
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Figure 7. Manual Modification indicator
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To view, change, and save calculations methods

The Calculations method can be used to calculate the ratio of the areas under 
the curve (AUC) of two different MRMs, for example, to normalize with an 
internal standard or to calculate percent conversion of a substrate to a product. 
Use the Calculations Editor to make changes to the calculations for the 
injections of an entire sequence. 

Because the MRM transitions can vary from sequence to sequence, the 
calculation formula can be set only for one sequence at a time. These changes 
are stored in the RFCalculations.dbxml file saved in the same directory as the 
raw data, and are available the next time that an RFDatabase.xml data file is 
opened. Any customized calculations are written to this file and used the next 
time the raw data is processed. This file can be deleted if you want to omit all 
customized calculations.

1 Click Edit > Calculations.
2 In the Calculations Editor dialog, find the Sequence you want to change and 

click the Expand button (Figure 8).

Figure 8. Calculations Editor
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Two tables are displayed for the sequence:
• The first table contains the experiment data. In Figure 8, the first table 

shows a row for each MRM. In Sequence 2, two MRMs were run on the 
instrument.  The information in pale yellow cells cannot be changed.  Only 
the Column Name can be changed in the first table.

• The second table allows you to change the Low Limits and the High 
Limits. If the corresponding MRM value falls below the low limit or above 
the high limit, the error is indicated by a color change on the displayed 
plate map, the sequence list, and the chromatogram entries.

You can add additional rows to the second table (Figure 9).

3 To add a row, click the cell below Column Name. Type the name of the new 
row. Complete the Equation, Low Limit, and High Limit text boxes.

4 Save the changes:
• Click Save to save the changes to the default Calculations method.
• Click Save As to save the changes as a template in a specific folder. 

This calculations method can be used to process future data. See “To open 
data files using a specific calculations method” on page 16.

Changes saved to the file are reflected in the sequence. New column headers 
appear at the beginning of the MRM data, just after the Injection and Well 
column (Figure 10).

Figure 9. Details of Sequence 2



Basic Tasks
To customize the viewable columns for a sequence

RapidFire Analyzer Quick Start Guide 27

To customize the viewable columns for a sequence

RapidFire Analyzer allows you to display all or some columns of information for 
an individual sequence.

1 In the Jump to sequence list, click a sequence number. 
2 In the Sequence View, click the Column Chooser button to the left of the first 

column (Figure 11).

3 In the Display Options dialog box, select or clear the check boxes for the 
sequence parameters to display. By default, all parameters are selected 
(Figure 12).

The Injection and Well columns are not listed because they cannot be hidden. 

Figure 10. Sequence with new column from the Calculations method

Figure 11. Select sequence to view
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4 Click OK to apply the changes and close the dialog box.

The Display Options changes are applied for as long as the Active Batch is open. 
If the Active Batch is closed, the Display Options changes are lost. The next time 
you open the Batch, all columns appear for all sequences in the Sequence View.

Figure 12. Display Options dialog box
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Customizing Workflow Preferences

The Workflow Preferences dialog box allows you to control the display of the 
chromatograms. 

To customize chromatogram viewing preference

Use the Chromatogram tab to control the default display settings for all 
chromatograms.
1 Click Tools > Preferences. 
2 In the Workflow Preferences dialog box, click the Chromatograms tab.

3 Change the settings as needed.
4 Click OK to save the changes. 

The changes are applied to the Chromatogram View.

Figure 13. Chromatograms tab
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To customize peak labeling preference

Use the Peak Labels tab to control the default display settings for all 
chromatograms when viewing multiple chromatograms at one time. 
1 Click Tools > Preferences.
2 In the Workflow Preferences dialog box, click the Peak Labels tab.

3 Change the settings as needed.
4 Click OK to save the changes. 

The changes are applied to the Chromatogram View.

Figure 14. Peak Labels tab
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Generating Reports

You can generate two types of report:
• an .xls report that contains all injection information
• a set of .csv reports, one for each plate

To generate a report for all injections in a batch

1 In the Injection View, expand a sequence to display individual injections.
2 Right-click any column for any injection in the sequence.
3 Click Export To Excel.
4 In the Save As dialog, select a folder to save the report and type a new File 

Name for the report.
5 Click Save.

The saved .xls report contains all injection information, including all user-defined 
values added in the Calculations Editor. The file is saved as an Excel workbook 
file.
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To generate a set reports for each plate in a batch

1 In the Injection View, expand a sequence to display individual injections.
2 Right-click any column for any injection in the sequence.
3 Click Export Plate Peak Data.
4 In the Browse For Folder dialog box, select an existing folder or create a new 

folder.

To make a new folder, click Make New Folder, and type a New Folder name.
5 Click Save to save the report.

RapidFire Analyzer creates one .csv file in the selected folder for each plate. 
Each report contains the MRM results from the sips taken from the plate. “-1” 
indicates no aspiration was performed on the well. 

The individual reports are saved in text format and are named Plate1.csv, 
Plate2.csv and so on. You can use any text editor or program that can read .csv 
files to view the files.
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